import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<type>[A-Za-z]{1})(?<subtype>[A-Za-z<]{1})(?<expcountry>[A-Za-z]{3})(?<docnumber>[0-9A-Za-z<]{9})(?<docnumbercheck>[0-9]{1})(?<complement>[0-9a-zA-Z<]{15})\\n(?<birthdate>[0-9]{6})(?<birthcheck>[0-9]{1})(?<sex>[mfMF]{1})(?<expiredate>[0-9]{6})(?<expirecheck>[0-9]{1})(?<nacionality>[A-Za-z]{3})(?<optional>[a-zA-Z0-9<]{11})(?<linecheck>[0-9]{1})\\n(?<lname>[A-Z]+)(?<lname2><[A-Z]+){0,}<<(?<spacing>[<]{0,})(?<fname>[A-Z]+)(?<mname1><[A-Z]+){0,}(?<namecomplement>[a-zA-Z<]+){0,}";
final String string = "IDCHES0002068<8<<<<<<<<<<<<<<<\n"
+ "8102287F1301014CHE<<<<<<<<<<<4\n"
+ "VADIS<<QUO<<<<<<<<<<<<<<<<<<<<\n\n"
+ "I<UTOD231458907<<<<<<<<<<<<<<<\n"
+ "7408122F1204159UTO<<<<<<<<<<<6\n"
+ "ERIKSSON<<ANNA<MARIA<<<<<<<<<<\n\n"
+ "I<NLDXI020DF236123456783<<<<<<\n"
+ "7208148F1108268NLD<<<<<<<<<<<9\n"
+ "VAN<DER<STEEN<<MARIANNE<LOUISE";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}