package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`'\\[0-7]{1,3}'`)
var str = `char x = '\077';
printf("%c", x);`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}