use strict;
my $str = '"Job Purpose: To produce all orders required by business volume and supervisor, quickly, efficiently, and to produce the highest quality product. Also, to produce all orders on an a la carte basis and to prep for buffets, banquets, salad bars and hors d’ oeuvres.Job Responsibilities: Display good customer relation skills and take initiative to greet guests in a friendly manner.Follow all company and safety and security policies and procedures; report accidents, injuries and unsafe work conditions to management; complete safety training and certifications.Ensure uniform and appearance is clean and professional, maintain confidentiality of proprietary information and protect company assets.Open each preparing and organizing the station and cooking all food necessary according to prep sheets to start meal service.Prepare all items for meal service including sauces, soups, setup, and any other items associated with the daily menu. Arrange and organize the line and steam table to facilitate meal period cooking and service.Prepare all orders as turned in by service staff and ensure all orders are cooked quickly and according to order; also ensures that food leaves the kitchen in peak condition.Learn menus, recipes, preparation, and presentation standards.Ensure all food is stored in proper containers and at proper storage and holding temperatures. Date all food containers and rotate as per the SOP, making sure that all perishables are kept at proper temperatures.Cook only sufficient food in advance to cover expected business volume and maintain quality.Prepare all food for next shift and the following day as required and directed by Supervisor.Maintain the work area, including all counter tops, utensils, equipment, and refrigeration in a clean and sanitary condition in accordance with state, county, and company health regulations and work safety regulations.Report to work for scheduled shift, on time and in uniform in accordance with company policy.Other duties as assigned by a managerJob Skills:Must be able to “prep” food products, using standardized food preparation techniques.Skillfully use hand tools or machines needed for work. Measure, cut, or otherwise work on materials or objects with great precision.Use arithmetic or shop geometry to figure amounts of material needed, dimensions to be followed and cost of materials.Must have the ability to follow instructions and to perform assigned tasks with limited supervision.Read recipes of items to be prepared.Minimum Requirements Job Qualifications: Education High School Diploma or equivalent preferred.Experience Minimum 3 months cooking experience at a full service restaurant or hotel."
';
my $regex = qr/([A-Z]{1,}[a-z]+\s+)*(Skills)[A-Za-z\,\;\-\s\"\'\:\d\“\”]+\./p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}