package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[~\{ (\w+) \}~\]`)
var str = `[~{ header }~]
<p>This is the home page</p>
[~{ footer }~]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}