// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?U)(?:"?([^"]*)"?,){2}"#).unwrap();
let string = "196778,\"df,fdfsdf\",\"4.4\",\"ds-sdads231-33\",\"mmh\",1023,1,\"20150,62519535TY\"";
let substitution = "bar";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}