using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[\/]{2})([a-z-]{1,})(?=[\.|:])";
string input = @"http://localhost:8080/test
https://test-app.uk.ru/test";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}