$re = '/(?<=[\/]{2})([a-z-]{1,})(?=[\.|:])/';
$str = 'http://localhost:8080/test
https://test-app.uk.ru/test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);