package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(https?:\/\/)?(ad.doubleclick.net\/)(N2909\/)?(adj\/)([\w.]+(.dfp))(\/)?(.*)$`)
var str = `<img src="http://i1.adis.ws/i/annsummers/01NWSEAS1002153_Z.jpg" height="100">`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}