$re = '/(?<street>.*) (?<number>.*)/';
$str = 'Street Blah Blah 34
Überbrückerstraße 24a.
Järvägstationg. 3/B
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);