package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(a(?1)c|b)$`)
var str = `b
abc
aabcc
aaabccc
But does NOT match any of:
ab
bc
aabc
abcc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}