re = /^(a(?1)c|b)$/m
str = 'b
abc
aabcc
aaabccc
But does NOT match any of:
ab
bc
aabc
abcc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end