using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![a-zA-Z])([A-Z]+)(?![a-zA-z])";
string input = @"PHP Hpukan PHP5 IVO VELKOV <TT> GoPHP PHPgo";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}