package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[img\]([:\/\.a-zA-Z0-9-_]+\.(jpg|gif|png|jpeg))\[\/img\]`)
var str = `[img]error.jpg" onerror="alert('oops')[/img]
[img]a-cute-bunny.jpg[/img]
[img]http://4.bp.blogspot.com/-JOqxgp-ZWe0/U3BtyEQlEiI/AAAAAAAAOfg/Doq6Q2MwIKA/s1600/google-logo-874x288.png[/img]`
var substitution = "<img src="$1" />"
fmt.Println(re.ReplaceAllString(str, substitution))
}