// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[img\]([:\/\.a-zA-Z0-9-_]+\.(jpg|gif|png|jpeg))\[\/img\]").unwrap();
let string = "[img]error.jpg\" onerror=\"alert('oops')[/img]
[img]a-cute-bunny.jpg[/img]
[img]http://4.bp.blogspot.com/-JOqxgp-ZWe0/U3BtyEQlEiI/AAAAAAAAOfg/Doq6Q2MwIKA/s1600/google-logo-874x288.png[/img]";
let substitution = "<img src=\"$1\" />";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}