$re = '/\w+\@\w+\.(com|ru|net)/';
$str = 'mail@mail.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);