#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b(\w)\S*?(\S@)(\S)\S*.(\S\.\S*)\b"
Local $sString = "anexample@gmail.com"
Local $sSubst = "$1****$2$3****$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)