use strict;
my $str = 'anexample@gmail.com';
my $regex = qr/\b(\w)\S*?(\S@)(\S)\S*.(\S\.\S*)\b/p;
my $subst = '$1****$2$3****$4';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";