$re = '/^(\d)\1+-(\d)\1+-(\d)\1+$/';
$str = '111-11-1111111';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);