import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s-\\s\\d*.\\d*\\sMB";
final String string = "<a href=\"http://example.com/a0j8nm5l3wo0\" target=_blank>01 song name.mp3 - 2.4 MB</a>\n"
+ "<a href=\"http://example.com/ic1jfhhzzfth\" target=_blank>02 song name.mp3 - 4.0 MB</a>\n"
+ "<a href=\"http://example.com/zo2nv6bzy6gd\" target=_blank>03 song name.mp3 - 3.3 MB</a>\n"
+ "<a href=\"http://example.com/5fyony1m4j0w\" target=_blank>04 song name.mp3 - 3.5 MB</a>\n"
+ "<a href=\"http://example.com/3imswet27clg\" target=_blank>05 song name.mp3 - 1.9 MB</a>\n"
+ "<a href=\"http://example.com/ml65j3gpdggv\" target=_blank>06 song name.mp3 - 3.4 MB</a>\n"
+ "<a href=\"http://example.com/hmuk8il0a04j\" target=_blank>07 song name.mp3 - 4.4 MB</a>\n"
+ "<a href=\"http://example.com/qx81e67ystd3\" target=_blank>08 song name.mp3 - 3.9 MB</a>\n"
+ "<a href=\"http://example.com/g6fo1s64vzkj\" target=_blank>09 song name.mp3 - 3.9 MB</a>\n"
+ "<a href=\"http://example.com/xo3hw4xyx372\" target=_blank>10 song name.mp3 - 3.6 MB</a>\n"
+ "<a href=\"http://example.com/ivcth22eqygd\" target=_blank>11 song name.mp3 - 3.3 MB</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}