using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"test\s([A-Z].+?)\s[a-z]";
string input = @"this is a test Ab Here here big";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}