$re = '/(start (nothing|var (bla)+)+ (end|final))+/';
$str = 'start var blabla end
start nothing end';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);