const regex = new RegExp('[^\\W_]{2,}', 'gm')
const str = `The rain in spain_stays
spain
The rain in \$spain_stays\$
The rain in \$spain_stays
The rain in spain_stays*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}