$re = '/^([^?#]+).*/m';
$str = 'https://studio.grabyo.com/home.jsp#stream/fBCyXMbtgHQ/share
https://studio.grabyo.com/studiolibrary.jsp?channelId=hkWw8oRUtPA
https://studio.grabyo.com/trim.jsp?campaignId=AQiJBGfoaJs&streamId=TCiHdVdqoBe
https://studio.grabyo.com/studiolibrary.jsp?streamId=TCiHdVdqoBe&galleryId=AQiJBGfoaJs
https://studio.grabyo.com/studiolibrary.jsp?campaignId=qzNPNPKTmry
https://studio.grabyo.com/trim.jsp?channelId=1dnc0Cjw9Ze
https://studio.grabyo.com/trim.jsp?campaignId=AQiJBGfoaJs
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);