import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!mailto)(?:https?|ftp):\\/(?:\\/?(?:[.#@?=]?[a-z0-9\\u00a1-\\uffff]+)+)+[.]?(?:png|jpe?g|gif)$";
final String string = "Allowed\n\n"
+ "http://hoogle.com.jpeg\n"
+ "ftp://foogle.com/bla.gif\n"
+ "https://localhost/test.jpg\n"
+ "http://127.0.0.1/test.jpg\n\n\n"
+ "Not Allowed\n\n"
+ "http://hoogle.com\n"
+ "not a url\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}