const regex = /(?s)<div[^>]*>.*<img.*src=\"([^"]+)\".*<\/div>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)<div[^>]*>.*<img.*src=\\"([^"]+)\\".*<\\\/div>', 'gmi')
const str = `<div class="header__logo"><a class="logotype" href="http://wpengine.com" data-wpel-link="internal"></a></div>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}