package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Trident\/7\.`)
var str = `Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.3; Trident/4.0; Touch)
Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.3; Trident/7.0; Touch)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}