$re = '/Trident\/7\./';
$str = 'Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.3; Trident/4.0; Touch)
Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.3; Trident/7.0; Touch)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);