import re
regex = re.compile(r"Trident\/7\.")
test_str = ("Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.3; Trident/4.0; Touch)\n"
"Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.3; Trident/7.0; Touch)")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")