import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\d]((\\+49|0049|0)1[567]\\d{1,2}([ \\-/]*\\d){7})(?!\\d)";
final String string = "################################### This is allowed ##########################\n"
+ "+49 15207930698\n"
+ "+49 15207955279\n"
+ "+49 915175461907\n\n\n"
+ "+4915207829969\n"
+ "+4915368831169\n"
+ "+491771399487\n"
+ "+4917697300278\n"
+ "+4915902955865\n"
+ "+491771789427\n"
+ "+4917697400179\n"
+ "+4915903904567\n"
+ "+4915902944599\n"
+ "+491739341284\n"
+ "+4915902944599\n"
+ "+4915903904567\n"
+ "The number +491739341284 with some text\n\n"
+ "Germany +4915255687865Total SMS: 6758\n"
+ "This number 015731294508 we need!\n"
+ "015731294508\n"
+ "015735995842\n\n"
+ "015168433343\n"
+ "Here:015731294508Hallo\n"
+ "Here:015731294508\n"
+ "<td>01573 / 1294-508</tr>\n"
+ "<td>015731294508</tr>\n"
+ "Eine Nummer: 01515 84 333 78\n"
+ "Wichtige Nummer:015731294508.\n"
+ "Noch eine Nummer-015731294508,\n"
+ "015731294508Hier\n\n"
+ "<td>01573 1294 508</tr>\n\n\n"
+ "################################### This is NOT allowed ##########################\n"
+ "012345678901234\n"
+ "123w345345345345\n"
+ "0123456789101191919\n"
+ "+4915902\n"
+ "+491590123\n"
+ "+4915903567\n"
+ "+49177178796\n"
+ "+49159039012341\n"
+ "+491590345985412\n\n"
+ "Invalid number +491590345985412 within text\n\n"
+ "+12127319863\n"
+ "+13322014056\n"
+ "+12126712234\n"
+ "+427532697710\n"
+ "+417868150810\n"
+ "+287533002875\n\n"
+ "+49 1739341284\n"
+ "(+49) 1739341284\n"
+ "+49 17 39 34 12 84\n"
+ "+49 (1739) 34 12 84\n"
+ "+(49) (1739) 34 12 84\n"
+ "+49 (1739) 34-12-84\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}