use strict;
my $str = '5/25/2022 14:13:05
5/25/2022 13:21:07 EDT
5/25/2022 17:07:39 GMT+01:00';
my $regex = qr`^([\d/]+\s[\d:]+).*`mp;
my $subst = '$1';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";