$re = '/^[^\S\n]{2}(name_template_2:)((?:\n[^\S\n]{4}\S.*)+)/m';
$str = 'templates:
name_template:
description: test_description
define: yes
write: true
name_template_2:
description: test_description2
define: false
write: true';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);