import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\bMove\\s+(?:\"[^\"]*\"|\\w+(?:\\.\\w+)*\\[\\w+]|\\d+)\\s+)\\w+(?:\\.\\w+)*";
final String string = " Move GLB.SPACES[B] GG_EWE.GG_EWE_IN.GP_EWE_FOCUS\n"
+ " Move 0 GG_EWE.GG_EWE_IN.GP_EWE_PRIORITY\n"
+ " Move \"667\" GG_EWE.GG_EWE_IN.GP_EWE_CODE\n"
+ " Move \"CUS01\" GG_EWE.GG_EWE_IN.GP_EWE_SOURCE[A]\n"
+ " Move \"Invalid customer type's for this screen\" GG_EWE.GG_EWE_IN.GP_EWE_DESC";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}