const regex = /(?<=\bMove\s+(?:"[^"]*"|\w+(?:\.\w+)*\[\w+]|\d+)\s+)\w+(?:\.\w+)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\bMove\\s+(?:"[^"]*"|\\w+(?:\\.\\w+)*\\[\\w+]|\\d+)\\s+)\\w+(?:\\.\\w+)*', 'gm')
const str = ` Move GLB.SPACES[B] GG_EWE.GG_EWE_IN.GP_EWE_FOCUS
Move 0 GG_EWE.GG_EWE_IN.GP_EWE_PRIORITY
Move "667" GG_EWE.GG_EWE_IN.GP_EWE_CODE
Move "CUS01" GG_EWE.GG_EWE_IN.GP_EWE_SOURCE[A]
Move "Invalid customer type's for this screen" GG_EWE.GG_EWE_IN.GP_EWE_DESC`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}