use strict;
my $str = ' Move GLB.SPACES[B] GG_EWE.GG_EWE_IN.GP_EWE_FOCUS
Move 0 GG_EWE.GG_EWE_IN.GP_EWE_PRIORITY
Move "667" GG_EWE.GG_EWE_IN.GP_EWE_CODE
Move "CUS01" GG_EWE.GG_EWE_IN.GP_EWE_SOURCE[A]
Move "Invalid customer type\'s for this screen" GG_EWE.GG_EWE_IN.GP_EWE_DESC';
my $regex = qr/(?<=\bMove\s+(?:"[^"]*"|\w+(?:\.\w+)*\[\w+]|\d+)\s+)\w+(?:\.\w+)*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}