import re
regex = re.compile(r"(?<=\bMove\s+(?:\"[^\"]*\"|\w+(?:\.\w+)*\[\w+]|\d+)\s+)\w+(?:\.\w+)*", flags=re.MULTILINE)
test_str = (" Move GLB.SPACES[B] GG_EWE.GG_EWE_IN.GP_EWE_FOCUS\n"
" Move 0 GG_EWE.GG_EWE_IN.GP_EWE_PRIORITY\n"
" Move \"667\" GG_EWE.GG_EWE_IN.GP_EWE_CODE\n"
" Move \"CUS01\" GG_EWE.GG_EWE_IN.GP_EWE_SOURCE[A]\n"
" Move \"Invalid customer type's for this screen\" GG_EWE.GG_EWE_IN.GP_EWE_DESC")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")