import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<token>[\\w\\-]+|BREAKING CHANGE)(?<seperator>: | #)(?<value>.*?(?=^([\\w\\-]+|BREAKING CHANGE)(: | #)))";
final String string = "Fixes: 849fa50662fb (\"bpf/verifier: refine retval R0 state \n"
+ "for bpf_get_stack helper\")\n"
+ "Reported-by: Lorenzo Fontana <fontanal\n"
+ "orenz@gmail.com>\n"
+ "Reported-by: Leonardo Di Donato <leodidonato@gmail.com>\n"
+ "Reported-by: John Fastabend <john.fastabend@gmail.com>\n\n"
+ "Signed-off-by: Daniel Borkmann <daniel@iogearbox.net>\n"
+ "Acked-by: Alexei Starovoitov <ast@kernel.org>\n"
+ "f\n"
+ "fffffff\n\n"
+ "Acked-by: John Fastabend <john.fastabend@gmail.com>\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}