const regex = /^(?<token>[\w\-]+|BREAKING CHANGE)(?<seperator>: | #)(?<value>.*?(?=^([\w\-]+|BREAKING CHANGE)(: | #)))/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<token>[\\w\\-]+|BREAKING CHANGE)(?<seperator>: | #)(?<value>.*?(?=^([\\w\\-]+|BREAKING CHANGE)(: | #)))', 'gms')
const str = `Fixes: 849fa50662fb ("bpf/verifier: refine retval R0 state
for bpf_get_stack helper")
Reported-by: Lorenzo Fontana <fontanal
orenz@gmail.com>
Reported-by: Leonardo Di Donato <leodidonato@gmail.com>
Reported-by: John Fastabend <john.fastabend@gmail.com>
Signed-off-by: Daniel Borkmann <daniel@iogearbox.net>
Acked-by: Alexei Starovoitov <ast@kernel.org>
f
fffffff
Acked-by: John Fastabend <john.fastabend@gmail.com>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}