# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<token>[\w\-]+|BREAKING CHANGE)(?<seperator>: | #)(?<value>.*?(?=^([\w\-]+|BREAKING CHANGE)(: | #)))"
test_str = ("Fixes: 849fa50662fb (\"bpf/verifier: refine retval R0 state \n"
"for bpf_get_stack helper\")\n"
"Reported-by: Lorenzo Fontana <fontanal\n"
"orenz@gmail.com>\n"
"Reported-by: Leonardo Di Donato <leodidonato@gmail.com>\n"
"Reported-by: John Fastabend <john.fastabend@gmail.com>\n\n"
"Signed-off-by: Daniel Borkmann <daniel@iogearbox.net>\n"
"Acked-by: Alexei Starovoitov <ast@kernel.org>\n"
"f\n"
"fffffff\n\n"
"Acked-by: John Fastabend <john.fastabend@gmail.com>\n\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.