#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s*\+\s*\n(\s*)"
Local $sString = "    public void plugins_group_id_not_textual() throws IOException {" & @CRLF & _
                "        pluginsFailure("{" +" & @CRLF & _
                "                "   \"plugins\": {" + "hola" + " & @CRLF & _
                "                "       \"onePlugin\": {" +" & @CRLF & _
                "                "           \"groupId\": 2" +" & @CRLF & _
                "                "       }" +" & @CRLF & _
                "                "   }" +" & @CRLF & _
                "                "}");"
Local $sSubst = "\n\1+ "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)