using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*\+\s*\n(\s*)";
string substitution = @"\n\1+ ";
string input = @" public void plugins_group_id_not_textual() throws IOException {
pluginsFailure(""{"" +
"" \""plugins\"": {"" + ""hola"" +
"" \""onePlugin\"": {"" +
"" \""groupId\"": 2"" +
"" }"" +
"" }"" +
""}"");";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}