package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*\+\s*\n(\s*)`)
var str = ` public void plugins_group_id_not_textual() throws IOException {
pluginsFailure("{" +
" \"plugins\": {" + "hola" +
" \"onePlugin\": {" +
" \"groupId\": 2" +
" }" +
" }" +
"}");`
var substitution = "\n\1+ "
fmt.Println(re.ReplaceAllString(str, substitution))
}