const regex = new RegExp('\\s*\\+\\s*\\n(\\s*)', 'g')
const str = ` public void plugins_group_id_not_textual() throws IOException {
pluginsFailure("{" +
" \\"plugins\\": {" + "hola" +
" \\"onePlugin\\": {" +
" \\"groupId\\": 2" +
" }" +
" }" +
"}");`;
const subst = `\n\1+ `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);