# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s*\+\s*\n(\s*)"
test_str = (" public void plugins_group_id_not_textual() throws IOException {\n"
" pluginsFailure(\"{\" +\n"
" \" \\\"plugins\\\": {\" + \"hola\" + \n"
" \" \\\"onePlugin\\\": {\" +\n"
" \" \\\"groupId\\\": 2\" +\n"
" \" }\" +\n"
" \" }\" +\n"
" \"}\");")
subst = "\\n\\1+ "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.