// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s*\+\s*\n(\s*)").unwrap();
let string = " public void plugins_group_id_not_textual() throws IOException {
pluginsFailure(\"{\" +
\" \\\"plugins\\\": {\" + \"hola\" +
\" \\\"onePlugin\\\": {\" +
\" \\\"groupId\\\": 2\" +
\" }\" +
\" }\" +
\"}\");";
let substitution = "\\n\\1+ ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}