const regex = /\b(?!\d*(\d)\1)[10]+\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!\\d*(\\d)\\1)[10]+\\b', 'gm')
const str = `no binary numbers here 3434.
Hey friend this is a 1.
Those are 1001, 1010, 1011, 1100, 1101
This is a long value 1010101010 and this one as well 1010101010101011
0 + 0 is a also a 0.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}