#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"host_ip"[\n\s.\w:",\[\]\/\?=\-;]*(\})"
Local $sString = "[" & @CRLF & _
" {" & @CRLF & _
" "city": "Bengalur"," & @CRLF & _
" "country": "IN"," & @CRLF & _
" "host_ip": "165.22.208.196"," & @CRLF & _
" "is_promoting": 0," & @CRLF & _
" "is_recommend": 0," & @CRLF & _
" "plugins": [" & @CRLF & _
" "ss://165.22.208.196:443?plugin=vest-udp;outbound=vmess"" & @CRLF & _
" ]," & @CRLF & _
" "server_load": 2," & @CRLF & _
" "service_type": 7" & @CRLF & _
" },"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")