using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""host_ip""[\n\s.\w:"",\[\]\/\?=\-;]*(\})";
string input = @"[
{
""city"": ""Bengalur"",
""country"": ""IN"",
""host_ip"": ""165.22.208.196"",
""is_promoting"": 0,
""is_recommend"": 0,
""plugins"": [
""ss://165.22.208.196:443?plugin=vest-udp;outbound=vmess""
],
""server_load"": 2,
""service_type"": 7
},";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}