// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"host_ip"[\n\s.\w:",\[\]\/\?=\-;]*(\})"#).unwrap();
let string = "[
{
\"city\": \"Bengalur\",
\"country\": \"IN\",
\"host_ip\": \"165.22.208.196\",
\"is_promoting\": 0,
\"is_recommend\": 0,
\"plugins\": [
\"ss://165.22.208.196:443?plugin=vest-udp;outbound=vmess\"
],
\"server_load\": 2,
\"service_type\": 7
},";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}