import Foundation
let pattern = #""host_ip"[\n\s.\w:",\[\]\/\?=\-;]*(\})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[
{
"city": "Bengalur",
"country": "IN",
"host_ip": "165.22.208.196",
"is_promoting": 0,
"is_recommend": 0,
"plugins": [
"ss://165.22.208.196:443?plugin=vest-udp;outbound=vmess"
],
"server_load": 2,
"service_type": 7
},
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)