re = /^blog\/(?P<blog_id>\d+)\/(?P<slug>[^\/\n]+)\/?$/m
str = 'blog/12/بلاگ-مثال'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end